CVE-2004-1026

NameCVE-2004-1026
DescriptionMultiple integer overflows in the image handler for imlib 1.9.14 and earlier, which is used by gkrellm and several window managers, allow remote attackers to cause a denial of service (application crash) and execute arbitrary code via certain image files.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-618-1, DSA-628-1
NVD severityhigh (attack range: remote)
Debian Bugs284925

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imlib2 (PTS)wheezy, wheezy (security)1.4.5-1+deb7u2fixed
jessie (security), jessie1.4.6-2+deb8u2fixed
buster, stretch, sid1.4.8-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imlibsource(unstable)1.9.14-17.1high284925
imlibsourcewoody1.9.14-2woody2highDSA-618-1
imlib+png2source(unstable)1.9.14-16.1high
imlib2source(unstable)1.1.2-2.1high
imlib2sourcewoody1.0.5-2woody2highDSA-628-1

Search for package or bug name: Reporting problems