CVE-2004-1170

NameCVE-2004-1170
Descriptiona2ps 4.13 allows remote attackers to execute arbitrary commands via shell metacharacters in the filename.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-612-1
NVD severityhigh (attack range: remote)
Debian Bugs283134

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
a2ps (PTS)wheezy, wheezy (security)1:4.14-1.1+deb7u1fixed
jessie1:4.14-1.3fixed
stretch1:4.14-2fixed
buster, sid1:4.14-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
a2pssource(unstable)1:4.13b-4.2high283134
a2pssourcewoody1:4.13b-4.2highDSA-612-1

Search for package or bug name: Reporting problems