CVE-2004-1304

NameCVE-2004-1304
DescriptionStack-based buffer overflow in the ELF header parsing code in file before 4.12 allows attackers to execute arbitrary code via a crafted ELF file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
file (PTS)jessie1:5.22+15-2+deb8u4fixed
jessie (security)1:5.22+15-2+deb8u7fixed
stretch1:5.30-1+deb9u2fixed
stretch (security)1:5.30-1+deb9u3fixed
buster, buster (security)1:5.35-4+deb10u1fixed
bullseye, sid1:5.37-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
filesource(unstable)4.12

Search for package or bug name: Reporting problems