CVE-2005-0021

NameCVE-2005-0021
DescriptionMultiple buffer overflows in Exim before 4.43 may allow attackers to execute arbitrary code via (1) an IPv6 address with more than 8 components, as demonstrated using the -be command line option, which triggers an overflow in the host_aton function, or (2) the -bh command line option or dnsdb PTR lookup, which triggers an overflow in the dns_build_reverse function.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-635-1, DSA-637-1
NVD severityhigh (attack range: local)
Debian Bugs290036

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exim4 (PTS)wheezy4.80-7+deb7u3fixed
wheezy (security)4.80-7+deb7u5fixed
jessie (security), jessie4.84.2-2+deb8u4fixed
stretch (security), stretch4.89-2+deb9u1fixed
buster, sid4.89-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
eximsource(unstable)3.36-13high290036
eximsourcewoody3.35-1woody4highDSA-635-1
exim-tlssource(unstable)(unfixed)high
exim-tlssourcewoody3.35-3woody3highDSA-637-1
exim4source(unstable)4.34-10high

Search for package or bug name: Reporting problems