CVE-2005-0397

NameCVE-2005-0397
DescriptionFormat string vulnerability in the SetImageInfo function in image.c for ImageMagick before 6.0.2.5 may allow remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via format string specifiers in a filename argument to convert, which may be called by other web applications.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-702-1
NVD severityhigh (attack range: remote)
Debian Bugs297990

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)wheezy1.3.16-1.1fixed
wheezy (security)1.3.16-1.1+deb7u10fixed
jessie1.3.20-3+deb8u1fixed
jessie (security)1.3.20-3+deb8u2fixed
stretch1.3.25-8fixed
buster, sid1.3.26-15fixed
imagemagick (PTS)wheezy8:6.7.7.10-5+deb7u4fixed
wheezy (security)8:6.7.7.10-5+deb7u17fixed
jessie8:6.8.9.9-5+deb8u9fixed
jessie (security)8:6.8.9.9-5+deb8u10fixed
stretch (security), stretch8:6.9.7.4+dfsg-11+deb9u1fixed
buster, sid8:6.9.7.4+dfsg-16fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksource(unstable)1.1.7-1high
imagemagicksource(unstable)6:6.0.6.2-2.2high297990
imagemagicksourcewoody4:5.4.4.5-1woody6highDSA-702-1

Search for package or bug name: Reporting problems