CVE-2005-1109

NameCVE-2005-1109
DescriptionThe filtering of URLs in JunkBuster before 2.0.2-r3 allows remote attackers to cause a denial of service (application crash) and possibly execute arbitrary code via heap corruption.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-713-1
NVD severityhigh (attack range: remote)
Debian Bugs304793

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
privoxy (PTS)wheezy, wheezy (security)3.0.19-2+deb7u3fixed
jessie (security), jessie3.0.21-7+deb8u1fixed
buster, sid, stretch3.0.26-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
junkbustersource(unstable)(unfixed)high304793
junkbustersourcewoody2.0.2-0.2woody1highDSA-713-1304793
privoxysource(unstable)(not affected)

Search for package or bug name: Reporting problems