CVE-2005-1228

NameCVE-2005-1228
DescriptionDirectory traversal vulnerability in gunzip -N in gzip 1.2.4 through 1.3.5 allows remote attackers to write to arbitrary directories via a .. (dot dot) in the original filename within a compressed file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-752-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gzip (PTS)buster, buster (security)1.9-3+deb10u1fixed
bullseye (security), bullseye1.10-4+deb11u1fixed
bookworm, sid1.12-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gzipsourcewoody1.3.2-3woody5DSA-752-1
gzipsource(unstable)1.3.5-10

Search for package or bug name: Reporting problems