CVE-2005-1527

NameCVE-2005-1527
DescriptionEval injection vulnerability in awstats.pl in AWStats 6.4 and earlier, when a URLPlugin is enabled, allows remote attackers to execute arbitrary Perl code via the HTTP Referrer, which is used in a $url parameter that is inserted into an eval function call.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-892-1
NVD severitymedium (attack range: remote)
Debian Bugs322591, 334833, 336137
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
awstats (PTS)squeeze6.9.5~dfsg-5fixed
wheezy7.0~dfsg-7fixed
jessie7.2+dfsg-1fixed
stretch, sid7.3+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
awstatssource(unstable)6.4-1.1medium322591, 334833, 336137
awstatssourcesarge6.4-1sarge1mediumDSA-892-1322591, 334833, 336137
awstatssourcewoody(not affected)DSA-892-1

Search for package or bug name: Reporting problems