CVE-2005-1796

NameCVE-2005-1796
DescriptionFormat string vulnerability in the curses_msg function in the Ncurses interface (ec_curses.c) for Ettercap before 0.7.3 allows remote attackers to execute arbitrary code.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-749-1
NVD severityhigh (attack range: remote)
Debian Bugs311615
Debian/oldstablenot vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ettercap (PTS)squeeze1:0.7.3-2.1+squeeze1fixed
squeeze (lts)1:0.7.3-2.1+squeeze2fixed
jessie, sid1:0.8.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ettercapsource(unstable)1:0.7.1-1.1high311615
ettercapsourcesarge1:0.7.1-1sarge1mediumDSA-749-1

Search for package or bug name: Reporting problems