CVE-2005-1852

NameCVE-2005-1852
DescriptionMultiple integer overflows in libgadu, as used in Kopete in KDE 3.2.3 to 3.4.1, ekg before 1.6rc3, GNU Gadu, CenterICQ, Kadu, and other packages, allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via an incoming message.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-767-1, DTSA-4-1
NVD severityhigh (attack range: remote)
Debian Bugs318970, 319443

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ekg (PTS)wheezy1:1.9~pre+r2854-1fixed
jessie1:1.9~pre+r2855-2fixed
stretch1:1.9~pre+r2855-5fixed
kdenetwork (PTS)wheezy4:4.8.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ekgsource(unstable)1:1.5+20050712+1.6rc3-1medium318970
ekgsourceetch1:1.5+20050808+1.6rc3-0etch1highDTSA-4-1
ekgsourcesarge1:1.5+20050411-5mediumDSA-767-1
kdenetworksource(unstable)4:3.3.2-5unimportant319443

Notes

Kopete embeds the vulnerable code, but it's only used as a fallback when
no shared lib version is found. As the Debian package has a dependency on
it the maintainer does not intent to fix it, see # 319443

Search for package or bug name: Reporting problems