DescriptionMultiple integer overflows in libgadu, as used in Kopete in KDE 3.2.3 to 3.4.1, ekg before 1.6rc3, GNU Gadu, CenterICQ, Kadu, and other packages, allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via an incoming message.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-767-1, DTSA-4-1
NVD severityhigh
Debian Bugs318970, 319443

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ekg (PTS)stretch1:1.9~pre+r2855-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


Kopete embeds the vulnerable code, but it's only used as a fallback when
no shared lib version is found. As the Debian package has a dependency on
it the maintainer does not intent to fix it, see # 319443

Search for package or bug name: Reporting problems