CVE-2005-1918

NameCVE-2005-1918
DescriptionThe original patch for a GNU tar directory traversal vulnerability (CVE-2002-0399) in Red Hat Enterprise Linux 3 and 2.1 uses an "incorrect optimization" that allows user-assisted attackers to overwrite arbitrary files via a crafted tar file, probably involving "/../" sequences with a leading "/".
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tar (PTS)buster1.30+dfsg-6fixed
bullseye1.34+dfsg-1+deb11u1fixed
bookworm1.34+dfsg-1.2+deb12u1fixed
trixie, sid1.35+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tarsource(unstable)1.14-2.2

Notes

1.14-2.2 is ok, maybe Debian was not-affected anyway

Search for package or bug name: Reporting problems