CVE-2005-2095

NameCVE-2005-2095
Descriptionoptions_identities.php in SquirrelMail 1.4.4 and earlier uses the extract function to process the $_POST variable, which allows remote attackers to modify or read the preferences of other users, conduct cross-site scripting XSS) attacks, and write arbitrary files.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-756-1
NVD severitymedium (attack range: remote)
Debian Bugs317094
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
squirrelmail (PTS)squeeze, squeeze (security)2:1.4.21-2fixed
sid, jessie, wheezy2:1.4.23~svn20120406-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
squirrelmailsource(unstable)2:1.4.4-6sarge1medium317094
squirrelmailsourcesarge2:1.4.4-6sarge1mediumDSA-756-1
squirrelmailsourcewoody1:1.2.6-4mediumDSA-756-1

Search for package or bug name: Reporting problems