CVE-2005-2148

NameCVE-2005-2148
DescriptionCacti 0.8.6e and earlier does not perform proper input validation to protect against common attacks, which allows remote attackers to execute arbitrary commands or SQL by sending a legitimate value in a POST request or cookie, then specifying the attack string in the URL, which causes the get_request_var function to return the wrong value in the $_REQUEST variable, which is cleansed while the original malicious $_GET value remains unmodified, as demonstrated in (1) graph_image.php and (2) graph.php.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-764-1
NVD severityhigh (attack range: remote)
Debian Bugs316590

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cacti (PTS)wheezy0.8.8a+dfsg-5+deb7u8fixed
wheezy (security)0.8.8a+dfsg-5+deb7u10fixed
jessie0.8.8b+dfsg-8+deb8u6fixed
jessie (security)0.8.8b+dfsg-8+deb8u4fixed
stretch0.8.8h+ds1-10fixed
buster, sid1.1.25+ds1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cactisource(unstable)0.8.6f-1high316590
cactisourcesarge0.8.6c-7sarge2highDSA-764-1
cactisourcewoody0.6.7-2.5highDSA-764-1

Search for package or bug name: Reporting problems