CVE-2005-2301

NameCVE-2005-2301
DescriptionPowerDNS before 2.9.18, when running with an LDAP backend, does not properly escape LDAP queries, which allows remote attackers to cause a denial of service (failure to answer ldap questions) and possibly conduct an LDAP injection attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-771-1
NVD severitymedium (attack range: remote)
Debian Bugs318798

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pdns (PTS)wheezy3.1-4.1fixed
wheezy (security)3.1-4.1+deb7u3fixed
jessie3.4.1-4+deb8u8fixed
jessie (security)3.4.1-4+deb8u7fixed
stretch4.0.3-1+deb9u2fixed
buster4.0.4-2fixed
sid4.1.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pdnssource(unstable)2.9.18-1medium318798
pdnssourcesarge2.9.17-13sarge1mediumDSA-771-1

Search for package or bug name: Reporting problems