CVE-2005-2368

NameCVE-2005-2368
Descriptionvim 6.3 before 6.3.082, with modelines enabled, allows external user-assisted attackers to execute arbitrary commands via shell metacharacters in the (1) glob or (2) expand commands of a foldexpr expression for calculating fold levels.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDTSA-12-1
NVD severityhigh (attack range: remote)
Debian Bugs320017

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vim (PTS)jessie2:7.4.488-7+deb8u3fixed
jessie (security)2:7.4.488-7+deb8u2fixed
stretch2:8.0.0197-4+deb9u1fixed
buster, sid2:8.1.0875-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vimsource(unstable)1:6.3-085+1medium320017
vimsourceetch1:6.3-085+0.0etch1mediumDTSA-12-1
vimsourcesarge1:6.3-071+1sarge1high

Notes

For some reason this was fixed through an upload to s-p-u, not stable-security

Search for package or bug name: Reporting problems