CVE-2005-2369

NameCVE-2005-2369
DescriptionMultiple integer signedness errors in libgadu, as used in ekg before 1.6rc2 and other packages, may allow remote attackers to cause a denial of service or execute arbitrary code.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-813-1, DTSA-2-1
NVD severityhigh (attack range: remote)
Debian Bugs323185, 350071
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ekg (PTS)squeeze1:1.8~rc1-1fixed
wheezy1:1.9~pre+r2854-1fixed
stretch, sid, jessie1:1.9~pre+r2855-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
centericqsource(unstable)4.20.0-9medium323185
centericqsourceetch4.20.0-8etch1mediumDTSA-2-1
centericqsourcesarge4.20.0-1sarge2highDSA-813-1
centericqsourcewoody(not affected)DSA-813-1
ekgsource(unstable)1:1.5+20050712+1.6rc2-1medium
ekgsourcesarge(not affected)
gaimsource(unstable)1:1.5.0-1medium350071
gaimsourcesarge(not affected)
gaimsourcewoody(not affected)

Notes

[woody] - gaim <not-affected> (affected code libgadu not present in woody)
[sarge] - gaim <not-affected> (old version of libgadu in gaim is not affected)
The fixes from centericq for integer overflows are all present in ekg from stable

Search for package or bug name: Reporting problems