CVE-2005-2448

NameCVE-2005-2448
DescriptionMultiple "endianness errors" in libgadu in ekg before 1.6rc2 allow remote attackers to cause a denial of service (invalid behavior in applications) on big-endian systems.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1318-1, DSA-813-1, DTSA-2-1, DTSA-4-1
NVD severitymedium (attack range: remote)
Debian Bugs323185
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ekg (PTS)squeeze1:1.8~rc1-1fixed
wheezy1:1.9~pre+r2854-1fixed
stretch, jessie, sid1:1.9~pre+r2855-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
centericqsource(unstable)4.20.0-9medium323185
centericqsourceetch4.20.0-8etch1mediumDTSA-2-1
centericqsourcesarge4.20.0-1sarge2mediumDSA-813-1
centericqsourcewoody(not affected)DSA-813-1
ekgsource(unstable)1:1.5+20050718+1.6rc3-1low
ekgsourceetch1:1.7~rc2-1etch1mediumDSA-1318-1
ekgsourcesarge1:1.5+20050411-7mediumDSA-1318-1

Search for package or bug name: Reporting problems