CVE-2005-2531

NameCVE-2005-2531
DescriptionOpenVPN before 2.0.1, when running with "verb 0" and without TLS authentication, does not properly flush the OpenSSL error queue when a client fails certificate authentication to the server and causes the error to be processed by the wrong client, which allows remote attackers to cause a denial of service (client disconnection) via a large number of failed authentication attempts.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
ReferencesDSA-851-1
Debian Bugs324167

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openvpn (PTS)buster2.4.7-1+deb10u1fixed
bullseye2.5.1-3fixed
bookworm, bookworm (security)2.6.3-1+deb12u2fixed
trixie2.6.7-1fixed
sid2.6.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openvpnsourcesarge2.0-1sarge1DSA-851-1
openvpnsource(unstable)2.0.2-1high324167

Search for package or bug name: Reporting problems