CVE-2005-2534

NameCVE-2005-2534
DescriptionRace condition in OpenVPN before 2.0.1, when --duplicate-cn is not enabled, allows remote attackers to cause a denial of service (server crash) via simultaneous TCP connections from multiple clients that use the same client certificate.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-851-1
NVD severitylow (attack range: remote)
Debian Bugs324167

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openvpn (PTS)wheezy2.2.1-8+deb7u3fixed
wheezy (security)2.2.1-8+deb7u5fixed
jessie (security), jessie2.3.4-5+deb8u2fixed
stretch2.4.0-6+deb9u2fixed
stretch (security)2.4.0-6+deb9u1fixed
buster, sid2.4.3-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openvpnsource(unstable)2.0.2-1high324167
openvpnsourcesarge2.0-1sarge1lowDSA-851-1

Search for package or bug name: Reporting problems