CVE-2005-2548

NameCVE-2005-2548
Descriptionvlan_dev.c in the VLAN code for Linux kernel 2.6.8 allows remote attackers to cause a denial of service (kernel oops from null dereference) via certain UDP packets that lead to a function call with the wrong argument, as demonstrated using snmpwalk on snmpd.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-922-1, DTSA-16-1
NVD severitymedium (attack range: remote)
Debian Bugs309308
Debian/oldstablenot vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux-2.6 (PTS)squeeze (security), squeeze2.6.32-48squeeze6fixed
squeeze (lts)2.6.32-48squeeze11fixed

The information above is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kernel-image-2.6.8-alphasourcesarge2.6.8-16sarge1mediumDSA-922-1
kernel-image-2.6.8-amd64sourcesarge2.6.8-16sarge1mediumDSA-922-1
kernel-image-2.6.8-hppasourcesarge2.6.8-6sarge1mediumDSA-922-1
kernel-image-2.6.8-i386sourcesarge2.6.8-16sarge1mediumDSA-922-1
kernel-image-2.6.8-ia64sourcesarge2.6.8-14sarge1mediumDSA-922-1
kernel-image-2.6.8-m68ksourcesarge2.6.8-4sarge1mediumDSA-922-1
kernel-image-2.6.8-s390sourcesarge2.6.8-5sarge1mediumDSA-922-1
kernel-image-2.6.8-sparcsourcesarge2.6.8-15sarge1mediumDSA-922-1
kernel-patch-powerpc-2.6.8sourcesarge2.6.8-12sarge1mediumDSA-922-1
kernel-source-2.6.8source(unstable)2.6.8-16sarge1low309308
kernel-source-2.6.8sourcesarge2.6.8-16sarge1mediumDSA-922-1
linux-2.6source(unstable)2.6.12-6low309308

Notes

Will appear in next kernel DSA, fixed in 2.6 since 2.6.9-rc2
2.6.12-1 contained a partially broken fix

Search for package or bug name: Reporting problems