CVE-2005-2627

NameCVE-2005-2627
DescriptionMultiple integer underflows in Kismet before 2005-08-R1 allow remote attackers to execute arbitrary code via (1) kernel headers in a pcap file or (2) data frame dissection, which leads to heap-based buffer overflows.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-788-1, DTSA-1-1
NVD severityhigh (attack range: remote)
Debian Bugs323386
Debian/oldstablenot vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kismet (PTS)squeeze2008-05-R1-4.1fixed
sid, jessie2013.03.R1b-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kismetsource(unstable)2005.08.R1-1high323386
kismetsourceetch2005.08.R1-0.1etch1highDTSA-1-1
kismetsourcesarge2005.04.R1-1sarge1mediumDSA-788-1
kismetsourcewoody(not affected)DSA-788-1

Search for package or bug name: Reporting problems