CVE-2005-2661

NameCVE-2005-2661
DescriptionFormat string vulnerability in the ParseBannerAndCapability function in main.c for up-imapproxy 1.2.3 and 1.2.4 allows remote IMAP servers to execute arbitrary code via format string specifiers in a banner or capability line.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-852-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
up-imapproxy (PTS)stretch1.2.8~svn20161210-2+deb9u1fixed
buster1.2.8~svn20171105-1fixed
bullseye, sid1.2.8~svn20171105-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
up-imapproxysource(unstable)1.2.4-2high
up-imapproxysourcesarge1.2.3-1sarge1DSA-852-1

Search for package or bug name: Reporting problems