CVE-2005-2700

NameCVE-2005-2700
Descriptionssl_engine_kernel.c in mod_ssl before 2.8.24, when using "SSLVerifyClient optional" in the global virtual host configuration, does not properly enforce "SSLVerifyClient require" in a per-location context, which allows remote attackers to bypass intended access restrictions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-805-1, DSA-807-1
NVD severityhigh (attack range: remote)
Debian Bugs327210

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)wheezy2.2.22-13+deb7u6fixed
wheezy (security)2.2.22-13+deb7u12fixed
jessie (security), jessie2.4.10-10+deb8u11fixed
stretch (security), stretch2.4.25-3+deb9u3fixed
buster, sid2.4.29-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2source(unstable)2.0.54-5medium327210
apache2sourcesarge2.0.54-5mediumDSA-805-1
libapache-mod-sslsource(unstable)2.8.24-1medium
libapache-mod-sslsourcesarge2.8.22-1sarge1mediumDSA-807-1
libapache-mod-sslsourcewoody2.8.9-2.5mediumDSA-807-1

Search for package or bug name: Reporting problems