CVE-2005-2811

NameCVE-2005-2811
DescriptionUntrusted search path vulnerability in Net-SNMP 5.2.1.2 and earlier, on Gentoo Linux, installs certain Perl modules with an insecure DT_RPATH, which could allow local users to gain privileges.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
net-snmp (PTS)jessie5.7.2.1+dfsg-1+deb8u1fixed
jessie (security)5.7.2.1+dfsg-1+deb8u2fixed
stretch (security), stretch5.7.3+dfsg-1.7+deb9u1fixed
bullseye, sid, buster5.7.3+dfsg-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
net-snmpsource(unstable)(not affected)

Notes

- net-snmp <not-affected> (Gentoo Portage specific configuration flaw)

Search for package or bug name: Reporting problems