CVE-2005-2959

NameCVE-2005-2959
DescriptionIncomplete blacklist vulnerability in sudo 1.6.8 and earlier allows local users to gain privileges via the (1) SHELLOPTS and (2) PS4 environment variables before executing a bash script on behalf of another user, which are not cleared even though other variables are.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-870-1
NVD severitymedium (attack range: local)
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sudo (PTS)squeeze, squeeze (security)1.7.4p4-2.squeeze.4fixed
squeeze (lts)1.7.4p4-2.squeeze.5fixed
wheezy1.8.5p2-1+nmu1fixed
wheezy (security)1.8.5p2-1+nmu2fixed
jessie1.8.10p3-1+deb8u2fixed
stretch, sid1.8.12-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sudosource(unstable)1.6.8p9-3medium
sudosourcesarge1.6.8p7-1.2mediumDSA-870-1
sudosourcewoody1.6.6-1.4mediumDSA-870-1

Search for package or bug name: Reporting problems