CVE-2005-2960

NameCVE-2005-2960
Descriptioncfengine 1.6.5 and 2.1.16 allows local users to overwrite arbitrary files via a symlink attack on temporary files used by vicf.in, a different vulnerability than CVE-2005-3137.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-835-1, DSA-836-1
NVD severitylow (attack range: local)
Debian Bugs332432, 332433

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cfengine2 (PTS)wheezy, jessie2.2.10-5fixed
buster, sid, stretch2.2.10-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cfenginesource(unstable)(unfixed)low332433
cfenginesourcesarge1.6.5-1sarge1lowDSA-835-1
cfenginesourcewoody1.6.3-9woody1lowDSA-835-1
cfengine2source(unstable)2.1.17-1low332432
cfengine2sourcesarge2.1.14-1sarge1lowDSA-836-1

Notes

maintainer does not think it's a hole, script is unused/broken

Search for package or bug name: Reporting problems