CVE-2005-2967

NameCVE-2005-2967
DescriptionFormat string vulnerability in input_cdda.c in xine-lib 1-beta through 1-beta 3, 1-rc, 1.0 through 1.0.2, and 1.1.1 allows remote servers to execute arbitrary code via format string specifiers in metadata in CDDB server responses when the victim plays a CD.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-863-1
NVD severityhigh (attack range: remote)
Debian Bugs332919, 333682

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xine-lib (PTS)wheezy1.1.21-1+deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xine-libsource(unstable)1.0.1-1.4medium332919, 333682
xine-libsourcesarge1.0.1-1sarge1highDSA-863-1
xine-libsourcewoody0.9.8-2woody4highDSA-863-1

Search for package or bug name: Reporting problems