CVE-2005-2976

NameCVE-2005-2976
DescriptionInteger overflow in io-xpm.c in gdk-pixbuf 0.22.0 in GTK+ before 2.8.7 allows attackers to cause a denial of service (crash) or execute arbitrary code via an XPM file with large height, width, and colour values, a different vulnerability than CVE-2005-3186.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-911-1, DSA-913-1
NVD severityhigh
Debian Bugs339431

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
gdk-pixbuf (PTS)stretch (security), stretch2.36.5-2+deb9u2fixed
buster2.38.1+dfsg-1fixed
bullseye, sid2.40.0+dfsg-5fixed
gtk+2.0 (PTS)stretch2.24.31-2fixed
buster2.24.32-3fixed
bullseye, sid2.24.32-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
gdk-pixbufsource(unstable)0.22.0-11medium339431
gdk-pixbufsourcesarge0.22.0-8.1DSA-913-1
gdk-pixbufsourcewoody0.17.0-2woody3DSA-913-1
gtk+2.0source(unstable)2.6.10-2
gtk+2.0sourcesarge2.6.4-3.1DSA-911-1
gtk+2.0sourcewoody2.0.2-5woody3DSA-911-1

Search for package or bug name: Reporting problems