CVE-2005-3109

NameCVE-2005-3109
DescriptionThe HFS and HFS+ (hfsplus) modules in Linux 2.6 allow attackers to cause a denial of service (oops) by using hfsplus to mount a filesystem that is not hfsplus.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-922-1
NVD severitylow (attack range: local)
Debian/oldstablenot vulnerable.
Debian/stablenot known to be vulnerable.
Debian/testingnot known to be vulnerable.
Debian/unstablenot known to be vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux-2.6 (PTS)squeeze (security), squeeze2.6.32-48squeeze6fixed
squeeze (lts)2.6.32-48squeeze11fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kernel-image-2.6.8-alphasourcesarge2.6.8-16sarge1lowDSA-922-1
kernel-image-2.6.8-amd64sourcesarge2.6.8-16sarge1lowDSA-922-1
kernel-image-2.6.8-hppasourcesarge2.6.8-6sarge1lowDSA-922-1
kernel-image-2.6.8-i386sourcesarge2.6.8-16sarge1lowDSA-922-1
kernel-image-2.6.8-ia64sourcesarge2.6.8-14sarge1lowDSA-922-1
kernel-image-2.6.8-m68ksourcesarge2.6.8-4sarge1lowDSA-922-1
kernel-image-2.6.8-s390sourcesarge2.6.8-5sarge1lowDSA-922-1
kernel-image-2.6.8-sparcsourcesarge2.6.8-15sarge1lowDSA-922-1
kernel-patch-powerpc-2.6.8sourcesarge2.6.8-12sarge1lowDSA-922-1
kernel-source-2.4.27source(unstable)(not affected)
kernel-source-2.6.8sourcesarge2.6.8-16sarge1lowDSA-922-1
linux-2.6source(unstable)(not affected)

Notes

- linux-2.6 <not-affected> (Fixed before upload into archive; 2.6.11.12)

Search for package or bug name: Reporting problems