CVE-2005-3137

NameCVE-2005-3137
DescriptionThe (1) cfmailfilter and (2) cfcron.in files for cfengine 1.6.5 allow local users to overwrite arbitrary files via a symlink attack on temporary files, a different vulnerability than CVE-2005-2960.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-835-1, DSA-836-1
NVD severitylow
Debian Bugs332432, 332433

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cfengine2 (PTS)stretch2.2.10-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cfenginesourcewoody1.6.3-9woody1DSA-835-1
cfenginesourcesarge1.6.5-1sarge1DSA-835-1
cfenginesource(unstable)(unfixed)low332433
cfengine2sourcesarge2.1.14-1sarge1DSA-836-1
cfengine2source(unstable)2.1.17-1low332432

Notes

maintainer does not think it's a hole, script is unused/broken

Search for package or bug name: Reporting problems