CVE-2005-3302

NameCVE-2005-3302
DescriptionEval injection vulnerability in bvh_import.py in Blender 2.36 allows attackers to execute arbitrary Python code via a hierarchy element in a .bvh file, which is supplied to an eval function call.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1039-1
NVD severityhigh (attack range: remote)
Debian Bugs330895
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
blender (PTS)squeeze2.49.2~dfsg-2fixed
wheezy2.63a-1+deb7u1fixed
jessie, sid2.72.b+dfsg0-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
blendersource(unstable)2.37a-1medium330895
blendersourcesarge2.36-1sarge1highDSA-1039-1
blendersourcewoody(not affected)

Notes

[woody] - blender <not-affected> (Woody's blender does not contain the bvh_import.py script)

Search for package or bug name: Reporting problems