CVE-2005-3318

NameCVE-2005-3318
DescriptionBuffer overflow in the _chm_decompress_block function in CHM lib (chmlib) before 0.37, as used in products such as KchmViewer, allows attackers to execute arbitrary code, a different vulnerability than CVE-2005-2930.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-886-1
NVD severitymedium (attack range: remote)
Debian Bugs335931

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
chmlib (PTS)wheezy2:0.40a-2fixed
buster, sid, jessie, stretch2:0.40a-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
chmlibsource(unstable)0.37-1medium335931
chmlibsourcesarge0.35-6sarge1mediumDSA-886-1

Search for package or bug name: Reporting problems