CVE-2005-3632

NameCVE-2005-3632
DescriptionMultiple buffer overflows in pnmtopng in netpbm 10.0 and earlier allow attackers to execute arbitrary code via a crafted PNM file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-904-1
NVD severitymedium (attack range: local)
Debian Bugs351639

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
netpbm-free (PTS)wheezy2:10.0-15fixed
jessie2:10.0-15.2fixed
stretch, sid2:10.0-15.3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
netpbm-freesource(unstable)2:10.0-10.1medium351639
netpbm-freesourcesarge2:10.0-8sarge2mediumDSA-904-1
netpbm-freesourcewoody2:9.20-8.5mediumDSA-904-1

Search for package or bug name: Reporting problems