DescriptionDirectory traversal vulnerability in tiny_mce_gzip.php in TinyMCE Compressor PHP before 1.06 allows remote attackers to read or include arbitrary files via a trailing null byte (%00) in the (1) theme, (2) language, (3) plugins, or (4) lang parameter.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wordpress (PTS)stretch (security), stretch4.7.5+dfsg-2+deb9u6fixed
buster, buster (security)5.0.10+dfsg1-0+deb10u1fixed
bullseye, sid5.4.2+dfsg1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
knowledgerootsource(unstable)(not affected)
moodlesource(unstable)(not affected)
wordpresssourceetch(not affected)


- knowledgeroot <not-affected> (fixed before first upload; see bug #381912)
- moodle <not-affected> (has newer version)
[etch] - wordpress <not-affected> (Vulnerable code not present)
this was possibly fixed before 2.5.1 in wordpress but since 2.5.1-3 wordpress
uses the system copy of tinymce and the exact fixed version is not
really determinably anymore

Search for package or bug name: Reporting problems