CVE-2005-4667

NameCVE-2005-4667
DescriptionBuffer overflow in UnZip 5.50 and earlier allows user-assisted attackers to execute arbitrary code via a long filename command line argument. NOTE: since the overflow occurs in a non-setuid program, there are not many scenarios under which it poses a vulnerability, unless unzip is passed long arguments when it is invoked from other programs.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1012-1
NVD severitylow (attack range: local)
Debian Bugs349794

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
unzip (PTS)wheezy6.0-8+deb7u5fixed
wheezy (security)6.0-8+deb7u6fixed
jessie6.0-16+deb8u3fixed
jessie (security)6.0-16+deb8u2fixed
buster, sid, stretch6.0-21fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
unzipsource(unstable)5.52-7low349794
unzipsourcesarge5.52-1sarge4lowDSA-1012-1
unzipsourcewoody5.50-1woody6lowDSA-1012-1

Search for package or bug name: Reporting problems