CVE-2005-4803

NameCVE-2005-4803
Descriptiongraphviz before 2.2.1 allows local users to overwrite arbitrary files via a symlink attack on temporary files. NOTE: this issue was originally associated with a different CVE identifier, CVE-2005-2965, which had been used for multiple different issues. This is the correct identifier.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-857-1
NVD severitylow (attack range: local)
Debian Bugs336985
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphviz (PTS)squeeze (security), squeeze2.26.3-5+squeeze2fixed
squeeze (lts)2.26.3-5+squeeze3fixed
wheezy, wheezy (security)2.26.3-14+deb7u2fixed
jessie, sid2.38.0-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphvizsource(unstable)2.2.1-1sarge1low336985
graphvizsourcesarge2.2.1-1sarge1lowDSA-857-1

Search for package or bug name: Reporting problems