CVE-2005-4816

NameCVE-2005-4816
DescriptionBuffer overflow in mod_radius in ProFTPD before 1.3.0rc2 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a long password.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1245-1
NVD severityhigh (attack range: remote)
Debian Bugs404751

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
proftpd-dfsg (PTS)wheezy, wheezy (security)1.3.4a-5+deb7u3fixed
jessie1.3.5-1.1+deb8u2fixed
jessie (security)1.3.5-1.1+deb8u1fixed
stretch1.3.5b-4fixed
buster, sid1.3.5d-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
proftpdsourcesarge1.2.10-15sarge4highDSA-1245-1
proftpd-dfsgsource(unstable)1.2.10+1.3.0rc5-1medium404751

Search for package or bug name: Reporting problems