CVE-2005-4890

NameCVE-2005-4890
DescriptionThere is a possible tty hijacking in shadow 4.x before 4.1.5 and sudo ...
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs628843, 657784

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
shadow (PTS)stretch1:4.4-4.1fixed
buster1:4.5-1.1fixed
bullseye, sid1:4.8.1-1fixed
sudo (PTS)stretch (security), stretch1.8.19p1-2.1+deb9u2fixed
buster1.8.27-1+deb10u2fixed
buster (security)1.8.27-1+deb10u1fixed
bullseye, sid1.9.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
shadowsource(unstable)1:4.1.5-1low628843
sudosource(unstable)1.7.4p4low657784

Notes

[squeeze] - shadow <no-dsa> (Minor issue)
[lenny] - shadow <no-dsa> (Minor issue)
https://bugzilla.redhat.com/show_bug.cgi?id=173008
sudo might be fixed earlier, use_pty present in stable

Search for package or bug name: Reporting problems