CVE-2006-0042

NameCVE-2006-0042
DescriptionUnspecified vulnerability in (1) apreq_parse_headers and (2) apreq_parse_urlencoded functions in Apache2::Request (Libapreq2) before 2.07 allows remote attackers to cause a denial of service (CPU consumption) via unknown attack vectors that result in quadratic computational complexity.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1000-2
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libapreq2 (PTS)wheezy2.13-1fixed
jessie2.13-4fixed
buster, sid, stretch2.13-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libapreq2source(unstable)2.07-1medium
libapreq2-perlsourcesarge2.04-dev-1sarge2mediumDSA-1000-2

Search for package or bug name: Reporting problems