CVE-2006-0058

NameCVE-2006-0058
DescriptionSignal handler race condition in Sendmail 8.13.x before 8.13.6 allows remote attackers to execute arbitrary code by triggering timeouts in a way that causes the setjmp and longjmp function calls to be interrupted and modify unexpected memory locations.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1015-1
NVD severityhigh (attack range: remote)
Debian Bugs358440
Debian/oldoldstablenot vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sendmail (PTS)squeeze8.14.3-9.4fixed
wheezy8.14.4-4fixed
jessie8.14.4-8fixed
stretch, sid8.14.9-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sendmailsource(unstable)8.13.6-1high358440
sendmailsourcesarge8.13.4-3sarge1highDSA-1015-1
sendmailsourcewoody8.12.3-7.2highDSA-1015-1

Search for package or bug name: Reporting problems