CVE-2006-0106

NameCVE-2006-0106
Descriptiongdi/driver.c and gdi/printdrv.c in Wine 20050930, and other versions, implement the SETABORTPROC GDI Escape function call for Windows Metafile (WMF) files, which allows attackers to execute arbitrary code, the same vulnerability as CVE-2005-4560 but in a different codebase.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesCVE-2005-4560, DSA-954-1
NVD severityhigh (attack range: remote)
Debian Bugs346197

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wine (PTS)wheezy1.4.1-4fixed
jessie1.6.2-20fixed
stretch1.8.7-2fixed
buster, sid2.0.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
winesource(unstable)0.9.2-1medium346197
winesourcesarge0.0.20050310-1.2highDSA-954-1

Search for package or bug name: Reporting problems