CVE-2006-0151

NameCVE-2006-0151
Descriptionsudo 1.6.8 and other versions does not clear the PYTHONINSPECT environment variable, which allows limited local users to gain privileges via a Python script, a variant of CVE-2005-4158.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-946-2
NVD severityhigh (attack range: local)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sudo (PTS)squeeze (security), squeeze1.7.4p4-2.squeeze.4fixed
squeeze (lts)1.7.4p4-2.squeeze.5fixed
wheezy1.8.5p2-1+nmu1fixed
wheezy (security)1.8.5p2-1+nmu2fixed
jessie1.8.10p3-1+deb8u2fixed
sid1.8.12-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sudosource(unstable)1.6.8p12-1medium
sudosourcesarge1.6.8p7-1.4highDSA-946-2
sudosourcewoody1.6.6-1.6highDSA-946-2

Notes

The whole black list approach is flawed, for the DSA we'll switch to
a white list approach of known to be safe env vars.

Search for package or bug name: Reporting problems