CVE-2006-0224

NameCVE-2006-0224
DescriptionBuffer overflow in Library of Assorted Spiffy Things (LibAST) 0.6.1 and earlier, as used in Eterm and possibly other software, allows local users to execute arbitrary code as the utmp user via a long -X command line argument (alternative configuration file name).
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-976-1
NVD severitymedium (attack range: local)
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libast (PTS)squeeze0.7-3fixed
wheezy0.7-6fixed
jessie, sid0.7-7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libastsource(unstable)0.7-1medium
libastsourcesarge0.6-0pre2003010606sarge1mediumDSA-976-1
libast1sourcewoody0.4-3woody2mediumDSA-976-1

Search for package or bug name: Reporting problems