CVE-2006-0292

NameCVE-2006-0292
DescriptionThe Javascript interpreter (jsinterp.c) in Mozilla and Firefox before 1.5.1 does not properly dereference objects, which allows remote attackers to cause a denial of service (crash) or execute arbitrary code via unknown attack vectors related to garbage collection.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1044-1, DSA-1046-1, DSA-1051-1
NVD severityhigh
Debian Bugs351442

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
firefox (PTS)sid70.0.1-1fixed
thunderbird (PTS)jessie1:52.8.0-1~deb8u1fixed
jessie (security)1:68.2.2-1~deb8u1fixed
stretch1:60.8.0-1~deb9u1fixed
stretch (security)1:68.2.2-1~deb9u1fixed
buster1:60.9.0-1~deb10u1fixed
buster (security)1:68.2.2-1~deb10u1fixed
bullseye1:60.9.0-1fixed
sid1:68.2.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
firefoxsource(unstable)1.5.dfsg+1.5.0.1-1351442
mozillasource(unstable)2:1.7.13-0.1
mozillasourcesarge2:1.7.8-1sarge5DSA-1046-1
mozilla-firefoxsourcesarge1.0.4-2sarge6
mozilla-thunderbirdsourcesarge1.0.2-2.sarge1.0.8
thunderbirdsource(unstable)1.5.0.2-1

Search for package or bug name: Reporting problems