CVE-2006-1060

NameCVE-2006-1060
DescriptionHeap-based buffer overflow in zgv before 5.8 and xzgv before 0.8 might allow user-assisted attackers to execute arbitrary code via a JPEG image with more than 3 output components, such as a CMYK or YCCK color space, which causes less memory to be allocated than required.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1037-1, DSA-1038-1
NVD severityhigh (attack range: remote)
Debian Bugs362288
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xzgv (PTS)wheezy, squeeze0.9+svn40-1fixed
jessie, sid0.9.1-3fixed
zgv (PTS)squeeze5.9-2fixed
wheezy5.9-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xzgvsource(unstable)0.8-5.1medium362288
xzgvsourcesarge0.8-3sarge1highDSA-1038-1
xzgvsourcewoody0.7-6woody3highDSA-1038-1
zgvsource(unstable)5.9-2high
zgvsourcesarge5.7-1.4highDSA-1037-1
zgvsourcewoody5.5-3woody3highDSA-1037-1

Search for package or bug name: Reporting problems