CVE-2006-1354

NameCVE-2006-1354
DescriptionUnspecified vulnerability in FreeRADIUS 1.0.0 up to 1.1.0 allows remote attackers to bypass authentication or cause a denial of service (server crash) via "Insufficient input validation" in the EAP-MSCHAPv2 state machine module.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1089-1
NVD severityhigh (attack range: remote)
Debian Bugs359042

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
freeradius (PTS)wheezy2.1.12+dfsg-1.2fixed
wheezy (security)2.1.12+dfsg-1.2+deb7u2fixed
jessie2.2.5+dfsg-0.2fixed
jessie (security)2.2.5+dfsg-0.2+deb8u1fixed
stretch (security), stretch3.0.12+dfsg-5+deb9u1fixed
buster, sid3.0.15+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
freeradiussource(unstable)1.1.0-1.2high359042
freeradiussourcesarge1.0.2-4sarge1highDSA-1089-1

Search for package or bug name: Reporting problems