CVE-2006-1629

NameCVE-2006-1629
DescriptionOpenVPN 2.0 through 2.0.5 allows remote malicious servers to execute arbitrary code on the client by using setenv with the LD_PRELOAD environment variable.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-1045-1
NVD severityhigh (attack range: remote)
Debian Bugs360559

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openvpn (PTS)wheezy2.2.1-8+deb7u3fixed
wheezy (security)2.2.1-8+deb7u5fixed
jessie (security), jessie2.3.4-5+deb8u2fixed
stretch2.4.0-6+deb9u2fixed
stretch (security)2.4.0-6+deb9u1fixed
buster, sid2.4.4-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openvpnsource(unstable)2.0.6-1medium360559
openvpnsourcesarge2.0-1sarge3highDSA-1045-1

Search for package or bug name: Reporting problems