CVE-2006-1655

NameCVE-2006-1655
DescriptionMultiple buffer overflows in mpg123 0.59r allow user-assisted attackers to trigger a segmentation fault and possibly have other impacts via a certain MP3 file, as demonstrated by mpg1DoS3. NOTE: this issue might be related to CVE-2004-0991, but it is not clear.
SourceCVE (at NVD; oss-sec, fulldisc, OSVDB, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, more)
ReferencesDSA-1074-1
NVD severitymedium (attack range: remote)
Debian Bugs361863
Debian/oldoldstablepackage mp3gain is vulnerable.
Debian/oldstablenot vulnerable.
Debian/stablenot vulnerable.
Debian/testingnot vulnerable.
Debian/unstablenot vulnerable.

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mp3gain (PTS)squeeze1.5.1-4vulnerable
wheezy1.5.2-r2-2+deb7u1fixed
mpg123 (PTS)squeeze1.12.1-3fixed
wheezy1.14.4-1fixed
stretch, sid, jessie1.20.1-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mp3gainsource(unstable)1.5.2-r2-6low
mp3gainsourcewheezy1.5.2-r2-2+deb7u1medium
mpg123source(unstable)0.59r-22medium361863
mpg123sourcesarge0.59r-20sarge1mediumDSA-1074-1

Notes

[squeeze] - mp3gain <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems