CVE-2006-1664

NameCVE-2006-1664
DescriptionBuffer overflow in xine_list_delete_current in libxine 1.14 and earlier, as distributed in xine-lib 1.1.1 and earlier, allows remote attackers to execute arbitrary code via a crafted MPEG stream.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
vlc (PTS)wheezy, wheezy (security)2.0.3-5+deb7u2fixed
jessie2.2.6-1~deb8u1fixed
jessie (security)2.2.7-1~deb8u1fixed
stretch2.2.6-1~deb9u1fixed
stretch (security)2.2.7-1~deb9u1fixed
buster, sid2.2.7-1fixed
xine-lib (PTS)wheezy1.1.21-1+deb7u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
vlcsource(unstable)(not affected)
xine-libsource(unstable)(not affected)

Notes

- xine-lib <not-affected> (Not reproducible with Debian version, see bug #363127)
- vlc <not-affected> (affected part of xine-lib code copy not present)

Search for package or bug name: Reporting problems