CVE-2006-1721

NameCVE-2006-1721
Descriptiondigestmd5.c in the CMU Cyrus Simple Authentication and Security Layer (SASL) library 2.1.18, and possibly other versions before 2.1.21, allows remote unauthenticated attackers to cause a denial of service (segmentation fault) via malformed inputs in DIGEST-MD5 negotiation.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDSA-1042-1
Debian Bugs361937

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
cyrus-sasl2 (PTS)buster, buster (security)2.1.27+dfsg-1+deb10u2fixed
bullseye (security), bullseye2.1.27+dfsg-2.1+deb11u1fixed
bookworm, sid2.1.28+dfsg-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
cyrus-sasl2sourcewoody(not affected)DSA-1042-1
cyrus-sasl2sourcesarge2.1.19-1.5sarge1DSA-1042-1
cyrus-sasl2source(unstable)2.1.19.dfsg1-0.2low361937
cyrus-sasl2-mitsource(unstable)(not affected)

Notes

- cyrus-sasl2-mit <not-affected> (does not install digest-md5)

Search for package or bug name: Reporting problems